Bitcoin Forum
August 21, 2018, 11:08:11 PM *
News: Latest stable version of Bitcoin Core: 0.16.2  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Not able to connect poclbm to bitcoin on another machine  (Read 2632 times)
fizgig
Newbie
*
Offline Offline

Activity: 27
Merit: 0


View Profile
March 04, 2011, 12:16:15 AM
 #1

I have bitcoind running on a linux machine with the following bitcoin.conf file:

Code:
rpcuser=username
rpcpassword=password
rpcallowip=*
rpcssl=1

I also did all the steps here:  http://www.bitcoin.org/wiki/doku.php?id=rpcssl  ...including testing the openssl connection from windows XP (where I want to run poclbm from) to bitcoind on the linux server.  The connection appears to work fine.

When I try to connect to bitcoind running on linux from windows xp using the commmand:
Code:
poclbm.exe --user=username --pass=password -o 192.168.2.10 -p 8332 -d0 --verbose --platform=0 -d0

I just get the "Problems communicating with bitcoin RPC" error message.  Any ideas what I can try?
1534892891
Hero Member
*
Offline Offline

Posts: 1534892891

View Profile Personal Message (Offline)

Ignore
1534892891
Reply with quote  #2

1534892891
Report to moderator
BOUNTY PORTALS
BLOG
WHERE BOUNTY MANAGEMENT
MEETS AUTOMATION
SIGNATURE CAMPAIGNS
TWITTER
FACEBOOK
MEDIA CAMPAIGNS
AND MORE!
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
Mahkul
Sr. Member
****
Offline Offline

Activity: 434
Merit: 250


Every saint has a past. Every sinner has a future.


View Profile
March 04, 2011, 12:57:29 AM
 #2

What if you try to connect from the local machine?
What if you put in the actual IP address instead of the wildcard? I am not sure whether you can just use *; in networking it is sometimes necessary to specify IPs like: *.*.*.*
fizgig
Newbie
*
Offline Offline

Activity: 27
Merit: 0


View Profile
March 04, 2011, 01:06:08 AM
 #3

I changed rpcallowip=* to rpcallowip=192.168.2.127 which is the address of the windows xp miner client and restarted bitcoind.  Still have the same error.

poclbm can connect to bitcoin if I run bitcoin on the xp machine.  I'm not sure how to run bitcoin on the machine running bitcoind since the machine is headless (no X server installed).

Any other suggestions?
Garrett Burgwardt
Sr. Member
****
Offline Offline

Activity: 476
Merit: 251


View Profile
March 04, 2011, 01:45:33 AM
 #4

I don't believe that you should have rpcallowip in the .conf file - that should be added as a launch statement, and probably the ssl one too. And make sure you run bitcoind with -server
fizgig
Newbie
*
Offline Offline

Activity: 27
Merit: 0


View Profile
March 04, 2011, 04:01:22 AM
 #5

I started bitcoind as so:

Code:
./bitcoind -server -rcpallowip=* -rpcssl=1

and also later tried:

Code:
./bitcoind -server -rcpallowip=192.168.2.* -rpcssl=1

Didn't make any difference.

The wiki seems to think that those options should work fine in the bitcoin.conf file:  http://www.bitcoin.org/wiki/doku.php?id=running_bitcoin

fizgig
Newbie
*
Offline Offline

Activity: 27
Merit: 0


View Profile
March 04, 2011, 04:19:32 AM
 #6

Got it working.  I got rid of the rpcssl=1 line in the conf file.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!